Milestone filtering partially non-functional

331
Defect
-
3.0.8
-
Ticket Filters
Fixed
Normal
Normal
4 years ago
3 years ago
0

Description

What did you do to cause this?

Clicked on the "19 open" link under a roadmap.

What page were you on?

Tickets page for a milestone.

What PHP and MySQL versions do you run?

5.3.3-7+squeeze14, 5.1.66-0+squeeze1

Describe the defect:

When trying to view the 3.0 milestone on this page, I am taken to a view of no tickets even though the roadmap page says there are 19 tickets.

I just created this ticket as part of the 3.0 milestone and it does not show up either (all others were originally created under a Traq 2.x installation).

Previous this milestone was named 2.x with the codename 2.x; this was changed to 3.0 and the codename removed - if this helps discover what is causing the issue.

Similar changes were made to the other milestones, but they appear to function as expected.

Furthermore, if I try to go to "Tickets" page directly, add a milestone filter, select only 3.0 and hit "Update", I am also met with no tickets.

Ticket History

4 years and 8 months ago by Jamie R. McPeek

I just noticed that I am able to get the 3.0 tickets to display properly if I use a milestone filter, selected 2.2.7, 2.2.8, 2.3 and choose is not.

4 years and 8 months ago by Jack

This is one of those really strange bugs.

4 years and 8 months ago by Jamie R. McPeek

I figured as much.

Please let me know if there is any additional information I can provide to help in your debugging efforts.

4 years and 8 months ago by Jack

  • Closed ticket as Fixed