#209 - Custom field value not stored
Type Defect
Status Invalid
Milestone 2.2
Version 2.1.1
Component Tickets
Priority Normal
Severity Normal
Owner Harry Lee
Assigned to Jack
Reported 11 years ago
Updated 9 years ago
Votes 0
Related tickets
Proposed time
Worked time

What did you do to cause this?

Create custom field "Reproducibility" with this code

<select name="reproducibility"> <option value="1"></option> <option value="2">Yes</option> <option value="3">No</option> </select>

What page were you on?

Tickets

Describe the defect:

New Ticket page shows the custom field with name and selection as expected, but after creating a new ticket, the selected custom field value is missing in Tickets page.

Ticket History

11 years and 11 months ago by Jack

  • Priority High Normal
  • Severity Major Normal

The field is not being remembered because you need to add the checking of that yourself.

11 years and 11 months ago by Jack

Here's the code for the percent field used here on the site.

<select name="%name%"> <?php foreach(array('0','10','20','30','40','50','60','70','80','90','100') as $_pct) { ?> <option value="<?php echo $_pct; ?>%" <?php echo (is_array($ticket) && @$ticket['extra'][$field['id']] == $_pct.'%' ? 'selected=\"selected\"' : ''); ?>><?php echo $_pct; ?>%</option> <?php } ?> </select>

Jack closed as Invalid 11 years and 10 months ago
harry reopened as Reopened 11 years and 10 months ago

Thanks for the reply Jack. I try your code in my 2.1.1 intallation, values are still not saved. What else I did wrong?

Code entered: <select name='pct'><?php foreach(array(0,25,50,75,100) as $_pct) { ?><option value='<?php echo $_pct; ?>'<?php echo (is_array($ticket) && $ticket['extra'][$field['id']] == $_pct.'' ? 'selected="selected"' : ''); ?>><?php echo $_pct; ?>%</option><?php } ?></select>

Step into \templates\traq.templates\new_ticket.php (line 115), the code was translated to: <select name='pct'><?php foreach(array(0,25,50,75,100) as \$_pct) { ?><option value='<?php echo \$_pct; ?>'<?php echo (is_array(\$ticket) && \$ticket['extra'][\$field['id']] == \$_pct.'' ? 'selected=\"selected\"' : ''); ?>><?php echo \$_pct; ?>%</option><?php } ?></select>

Is that something in my PHP setting?

Jack closed as Invalid 11 years and 10 months ago

You may need to type it in yourself if copy/pasting isn't working.

11 years and 10 months ago by Jack

If you need further help, the forums are a better choice as this place is setup for actual issues, not discussion and help.