#104 - [0.6]Browse Source not working
Type Defect
Status Closed
Milestone 0.6.1
Version -
Component Core
Priority Highest
Severity Major
Owner Mythos
Assigned to Jack
Reported 13 years ago
Updated 9 years ago
Votes 0
Related tickets
Proposed time
Worked time

Sorry for late ticket, but I geht this error: [code] Fatal error: Uncaught exception 'Exception' with message 'String could not be parsed as XML' in K:\Server\Webserver\htdocs\bugtracker\include\svn.class.php:105 Stack trace: #0 K:\Server\Webserver\htdocs\bugtracker\include\svn.class.php(105): SimpleXMLElement->__construct('') #1 K:\Server\Webserver\htdocs\bugtracker\handlers\browsesvn.php(40): Traq_Subversion->info('') #2 K:\Server\Webserver\htdocs\bugtracker\handlers\project.php(474): include('K:\Server\Webse...') #3 K:\Server\Webserver\htdocs\bugtracker\index.php(31): include('K:\Server\Webse...') #4 {main} thrown in K:\Server\Webserver\htdocs\bugtracker\include\svn.class.php on line 105 [/code]

Ticket History

13 years and 7 months ago by Mythos

Here's the error again, because the code bb code is broken:

Fatal error: Uncaught exception 'Exception' with message 'String could not be parsed as XML' in K:\Server\Webserver\htdocs\bugtracker\include\svn.class.php:105 Stack trace: #0 K:\Server\Webserver\htdocs\bugtracker\include\svn.class.php(105): SimpleXMLElement->__construct('') #1 K:\Server\Webserver\htdocs\bugtracker\handlers\browsesvn.php(40): Traq_Subversion->info('') #2 K:\Server\Webserver\htdocs\bugtracker\handlers\project.php(474): include('K:\Server\Webse...') #3 K:\Server\Webserver\htdocs\bugtracker\index.php(31): include('K:\Server\Webse...') #4 {main} thrown in K:\Server\Webserver\htdocs\bugtracker\include\svn.class.php on line 105

13 years and 7 months ago by Mythos

  • Priority High Highest

13 years and 7 months ago by Jack

  • Milestone 2.0 0.6.1

Does your server have Subversion installed and accessible via the command line, and what is the URL you are trying to use to access the Subversion repository.

13 years and 7 months ago by Mythos

I link to an external repo ... but my server allows the php functions (localhost, can open other websites)

https://wowcrackz-mango.svn.sourceforge.net/svnroot/wowcrackz-mango

That's the external repo @ sourceforge ... in older versions, it worked ;)

13 years and 7 months ago by Mythos

Doesn't work with https://wowcrackz-mango.svn.sourceforge.net/svnroot/wowcrackz-mango/trunk/ , too... I thought it's the trunk who causes the error, but now ...

Jack closed as Invalid 13 years and 7 months ago

The problem is not in Traq, but the server, or more the URL.

The URL is using the HTTPS protocol, try using the normal HTTP protocol, and it should work.

Example: [b]http://[/b]wowcrackz-mango.svn.sourceforge.net/svnroot/wowcrackz-mango

Instead of: [b]https://[/b]wowcrackz-mango.svn.sourceforge.net/svnroot/wowcrackz-mango

Mythos reopened as Reopened 13 years and 7 months ago

13 years and 7 months ago by Jack

What version of Subversion are you using?

I've tested the URL with version 1.5.6

13 years and 7 months ago by Mythos

What do you mean? I use TortoiseSVN (newest one) and don't own a server...

13 years and 7 months ago by Jack

If you open Terminal, or Command Prompt (Windows key + R, then type: cmd) on Windows, and type in: "svn --version" (without the quotes) what do you get?

13 years and 7 months ago by Mythos

Doesn't work, the command doesn't exist ...

Mythos closed as Closed 13 years and 7 months ago

Well doesn't matter, develop on 2.0 and everything gets better :)