Use an established framework

453
Enhancement
Jack
Jack
4.0
-
Core
Completed
Highest
Normal
1 year ago
1 year ago
0

Description

Development on 4.0 has stalled due to working on Avalon and Traq at the same time and with reduced time to work on Traq it would be better to switch to an already established framework such as Symfony or Laravel.

This would increase the development speed of 4.0 and future versions.

Likely candidates are:

  1. Symfony
  2. Laravel

Attachments

Ticket History

1 year and 4 months ago by Jack

  • Closed ticket as Completed

Development on Traq 4.0 has been restarted, the chosen framework is Laravel.

1 year and 3 months ago by Jack

  • Added attachment traq-4-roadmap.png